Commit a6481eeb authored by Dominique Marcadet's avatar Dominique Marcadet

Merge branch '34-update-to-current-versions' into 'master'

Resolve "update to current versions"

Closes #34

See merge request RiseClipseGroup/RiseClipseDeveloper!39
parents 716b72d0 f1246eeb
......@@ -21,13 +21,14 @@
<module>../../RiseClipseDeveloper</module>
<module>../../RiseClipseMain</module>
<module>../../RiseClipseEditor</module>
<module>../../RiseClipseMetamodel_SCL2003</module>
<module>../../RiseClipseMetamodel_Cim</module>
<module>../../RiseClipseMetamodel_Cim16</module>
<module>../../RiseClipseMetamodel_EntsoeCim16</module>
<module>../../RiseClipseMetamodel_Cim17</module>
<module>../../RiseClipseMetamodel_iec61970cim17</module>
<module>../../RiseClipseMetamodel_iec61970cim17_iec61968cim13</module>
<module>../../RiseClipseMetamodel_SCL2003</module>
<module>../../RiseClipseMetamodel_NSD2016</module>
<module>../../RiseClipseOCLValidator</module>
<!--
To build standalone tools, eclipse dependencies must be installed using the command
......@@ -42,9 +43,10 @@
using the provided org.antlr.runtime-3.2.0.zip (unzip it in ~/.m2/repository/
replacing the 4.0.0 version)
-->
<module>../../RiseClipseOCLValidator_SCL2003</module>
<module>../../RiseClipseValidator_SCL2003</module>
<module>../../RiseClipseOCLValidator_EntsoeCim16</module>
<module>../../RiseClipseDistribution</module>
</modules>
</project>
......@@ -17,31 +17,29 @@
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
<tycho-version>1.1.0</tycho-version>
<tycho-version>1.3.0</tycho-version>
<unleash-maven-plugin-version>2.8.0</unleash-maven-plugin-version>
<unleash-scm-provider-git-version>2.1.0</unleash-scm-provider-git-version>
<unleash-maven-plugin-version>2.9.3</unleash-maven-plugin-version>
<unleash-scm-provider-git-version>2.2.0</unleash-scm-provider-git-version>
<eclipse-equinox-version>1.3.400</eclipse-equinox-version>
<!--
Current (2018-04-06, Oxygen) EMF version is 2.13.0
it is found by tycho when building Eclipse plugins (using eclipse-oxygen repository)
but not by maven-shade-plugin when building independant tools.
On Maven central, only version 2.12 is available (and EMF is still
not on repo.eclipse.org)
<eclipse-emf-version>2.13.0</eclipse-emf-version>
-->
<eclipse-emf-version>2.12.0</eclipse-emf-version>
<eclipse-ocl-version>1.3.0</eclipse-ocl-version>
<maven-shade-plugin-version>3.2.1</maven-shade-plugin-version>
<eclipse-equinox-app-version>1.4.100</eclipse-equinox-app-version>
<eclipse-emf-ecore-version>2.17.0</eclipse-emf-ecore-version>
<eclipse-emf-common-version>2.15.0</eclipse-emf-common-version>
<eclipse-emf-xmi-version>2.15.0</eclipse-emf-xmi-version>
<eclipse-ocl-version>1.7.0</eclipse-ocl-version>
<log4j-version>1.2.17</log4j-version>
<javax-inject-version>1</javax-inject-version>
</properties>
<repositories>
<repository>
<id>eclipse-oxygen</id>
<url>http://download.eclipse.org/releases/oxygen</url>
<id>eclipse-2019-03</id>
<url>http://download.eclipse.org/releases/2019-03</url>
<layout>p2</layout>
</repository>
</repositories>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment