Ce serveur Gitlab sera éteint le 30 juin 2020, pensez à migrer vos projets vers les serveurs gitlab-research.centralesupelec.fr et gitlab-student.centralesupelec.fr !

Commit 168f9651 authored by Dimitri Fontaine's avatar Dimitri Fontaine

Documentation review (el-get-describe, some upgrade notes, etc)

parent f96f2b62
......@@ -236,6 +236,13 @@ general purposes hooks facilities: +el-get-post-install-hooks+ and
Yes, ok.
M-x el-get-describe::
Prompt for a package name, with completion, then open an +*Help*+ window
with details about the selected package. Those include current status,
website, description, installation method, full recipe, and buttons to
easily install, update or remove the package.
M-x el-get-sync::
Synchronously install any "required" package and init any "installed" one.
......@@ -301,6 +308,32 @@ M-x el-get-emacswiki-refresh::
+~/.emacs.d/el-get/el-get/recipes/emacswiki/+ if you didn't change
+el-get-dir+.
=== Useful functions
el-get-package-types-alist (statuses &rest types)::
Return an alist of package names that are of given types. Only consider
packages whose status is `member' of STATUSES, which defaults to
installed, required and removed.
ELISP> (el-get-package-types-alist "installed" 'cvs 'emacswiki)
((emacs-w3m . cvs)
(rect-mark . emacswiki)
(icomplete+ . emacswiki)
(php-mode-improved . emacswiki)
(rainbow-delimiters . emacswiki)
(goto-last-change . emacswiki)
(emacs-goodies-el . cvs))
el-get-extra-packages (&rest packages)::
Return installed or required packages that are not in given package
list.
ELISP> (el-get-extra-packages dim-packages)
((verbiste "installed")
(package "installed"))
== Internals
TODO: explain the symlinks in +~/.emacs.d/el-get+. For now, read the source
......@@ -315,6 +348,15 @@ using copy paste. Here's the patch: https://github.com/dimitri/el-get/commit/63e
== Upgrade Notes
=== Upgrading to 3.0
Please remind that +3.0+ is a development branch. A change has been
included so that +el-get-sources+ is now only another source for recipes,
and +(el-get '...)+ will now only install and initialize known "required"
and "installed" packages.
The documentation has been updated to detail how to upgrade.
=== Upgrading to 1.1
==== Package Status
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment