Ce serveur Gitlab sera éteint le 30 juin 2020, pensez à migrer vos projets vers les serveurs gitlab-research.centralesupelec.fr et gitlab-student.centralesupelec.fr !

Commit 19c3fa3f authored by Rüdiger Sonderfeld's avatar Rüdiger Sonderfeld

el-get-describe: Inform user about minimum version requirement.

* el-get-list-packages.el (el-get-describe-1): Inform user about
  minimum version requirement.
Signed-off-by: 's avatarRüdiger Sonderfeld <ruediger@c-plusplus.de>
parent 60050503
......@@ -83,6 +83,7 @@ matching REGEX with TYPE and ARGS as parameter."
(descr (plist-get def :description))
(type (el-get-package-method def))
(builtin (plist-get def :builtin))
(minimum-version (plist-get def :minimum-emacs-version))
(url (plist-get def :url))
(depends (plist-get def :depends)))
(princ (format "%s is an `el-get' package. " name))
......@@ -126,6 +127,12 @@ matching REGEX with TYPE and ARGS as parameter."
(format "`%s'" depends) "`\\([^`']+\\)"
'el-get-help-describe-package depends))
(princ ".\n"))
(when minimum-version
(princ (format "Requires minimum Emacs version: %s." minimum-version))
(when (version-list-< (version-to-list emacs-version)
(el-get-version-to-list minimum-version))
(princ (format " Warning: Your Emacs is too old (%s)!" emacs-version)))
(princ "\n"))
(if (eq type 'builtin)
(princ (format "The package is built-in since Emacs %s.\n\n" builtin))
(princ (format "The default installation method is %s%s.\n\n" type
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment