Ce serveur Gitlab sera éteint le 30 juin 2020, pensez à migrer vos projets vers les serveurs gitlab-research.centralesupelec.fr et gitlab-student.centralesupelec.fr !

Commit c9b33627 authored by Dimitri Fontaine's avatar Dimitri Fontaine

Release stable version 2.1

parent 321afd55
...@@ -11,6 +11,30 @@ documentation you now depend on, and finally call your own ...@@ -11,6 +11,30 @@ documentation you now depend on, and finally call your own
+:post-init+ function for you to setup the extension. Or call it a +:post-init+ function for you to setup the extension. Or call it a
package. package.
== Status and Version Numbers
Current +el-get+ status is stable, ready for daily use and packed with extra
features that make life easier. There are some more things we could do, as
always, but they will be about smoothing things further.
=== Last released version
+el-get+ version 2.1 is available, with a boatload of features, including
autoloads support, byte-compiling in an external "clean room" Emacs
instance, custom support, lazy initialisation support (defering all init
functions to +eval-after-load+), and multi repositories +ELPA+ support.
=== Version numbering
Version String are now inspired by how Emacs itself numbers its version.
First is the major version number, then a dot, then the minor version
number. The minor version number is 0 when still developping the next major
version. So 2.0 is a developer release while 2.1 will be the next stable
release.
Please not that this versioning policy has been picked while backing
1.2~dev, so 1.0 was a "stable" release in fact. Ah, history.
== How to Install it? == How to Install it?
Here's the 'lazy installer': Here's the 'lazy installer':
...@@ -259,9 +283,11 @@ Please see the documentation for the +el-get-methods+ and provide a patch! ...@@ -259,9 +283,11 @@ Please see the documentation for the +el-get-methods+ and provide a patch!
Adding +bzr+ support for example was only about writing 2 functions, mostly Adding +bzr+ support for example was only about writing 2 functions, mostly
using copy paste. Here's the patch: https://github.com/dimitri/el-get/commit/63e9018102bdeb7b6d9136db231adcd983087217#L0R437 using copy paste. Here's the patch: https://github.com/dimitri/el-get/commit/63e9018102bdeb7b6d9136db231adcd983087217#L0R437
== Gotchas == Upgrade Notes
=== Upgrading to 1.1
=== Package Status ==== Package Status
+el-get+ will now save some package status information into the file +el-get+ will now save some package status information into the file
+el-get-status-file+, it's a property list of the package symbol and its +el-get-status-file+, it's a property list of the package symbol and its
......
...@@ -4,7 +4,7 @@ ...@@ -4,7 +4,7 @@
;; ;;
;; Author: Dimitri Fontaine <dim@tapoueh.org> ;; Author: Dimitri Fontaine <dim@tapoueh.org>
;; URL: http://www.emacswiki.org/emacs/el-get.el ;; URL: http://www.emacswiki.org/emacs/el-get.el
;; Version: 2.0 ;; Version: 2.1
;; Created: 2010-06-17 ;; Created: 2010-06-17
;; Keywords: emacs package elisp install elpa git git-svn bzr cvs svn darcs hg ;; Keywords: emacs package elisp install elpa git git-svn bzr cvs svn darcs hg
;; apt-get fink pacman http http-tar emacswiki ;; apt-get fink pacman http http-tar emacswiki
...@@ -24,12 +24,12 @@ ...@@ -24,12 +24,12 @@
;; ;;
;; So 2.0 is a developer release while 2.1 will be the next stable release. ;; So 2.0 is a developer release while 2.1 will be the next stable release.
;; ;;
;; Please not that this versioning policy has been picked while backing ;; Please note that this versioning policy has been picked while backing
;; 1.2~dev, so 1.0 was a "stable" release in fact. Ah, history. ;; 1.2~dev, so 1.0 was a "stable" release in fact. Ah, history.
;;; Change Log: ;;; Change Log:
;; ;;
;; 2.0 - WIP - Still growing, getting lazy ;; 2.1 - 2010-05-25 - Still growing, getting lazy
;; ;;
;; - Add support for autoloads, per Dave Abrahams ;; - Add support for autoloads, per Dave Abrahams
;; - fix 'wait support for http (using sync retrieval) ;; - fix 'wait support for http (using sync retrieval)
...@@ -133,7 +133,7 @@ ...@@ -133,7 +133,7 @@
(defgroup el-get nil "el-get customization group" (defgroup el-get nil "el-get customization group"
:group 'convenience) :group 'convenience)
(defconst el-get-version "1.1~dev" "el-get version number") (defconst el-get-version "2.1" "el-get version number")
(defcustom el-get-post-init-hooks nil (defcustom el-get-post-init-hooks nil
"Hooks to run after a package init. "Hooks to run after a package init.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment